Ruby

We recommend Ruby 1.8.7 or Ruby 1.9.2for use with Rails. Ruby 1.8.6 and earlier are not supported, neither is version 1.9.1.

Source: Compile it yourself
Windows installer: Ruby, popular extensions, editor
OS X 10.5+: Included with developer tools
(then do "gem update rails")


RubyGems

RubyGems is the standard Ruby package manager. It's similar to apt-get, emerge, and other OS package managers.

Download 
(extract, then run "ruby setup.rb")


Rails

With RubyGems loaded, you can install all of Rails and its dependencies through the command line:

gem install rails

New versions of Rails can be installed the same way. Rails can also be downloaded as stand-alone packages.


Make your application

Create your application skeleton and start the server:

rails new path/to/your/new/application
cd path/to/your/new/application
rails server

You're running Ruby on Rails! Follow the instructions on http://localhost:3000.


Extending Rails
with lots of plugins

There's a world of extensions to the core Rails framework through plugins. They provide cool functionality that may not be needed by most of the people most of the time, but still serve a spot for those exceptions where you do need more. Read more about plugins at Agile Web Development.


Editors

TextMate on OS X has long been the favored Rails editor, but the classic editors are still going strong. See VIM for Rails and Emacs for Rails. For a full-on IDE, check out RadRailsRubyMine3rd Rail, or Netbeans for Ruby.

저작자 표시 비영리 동일 조건 변경 허락
신고

'☆Develpoer > └ Ruby on Rails' 카테고리의 다른 글

Rails 프로젝트 생성  (0) 2011.07.18
RubyonRails install on windows platform  (0) 2011.07.18
Ruby on Rails Windows  (0) 2011.07.17
Rubyonrails Download  (0) 2011.07.17
Ruby on Rails 참고 링크  (0) 2011.07.12
Ruby on Rails 도입에 고려할점  (0) 2011.07.12

+ Recent posts